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Introduction
What is PhoneFile PRO?
PhoneFile PRO will revolutionise the way you manage the contact names
and phone numbers that you can store in your GSM mobile phone’s SIM
card by enabling you to access them directly from your PC. This is not
limited in any way by the model of your phone or the GSM network that
you use.
PhoneFile PRO runs on most PCs that have a Windows™ operating
system installed, including Windows 3.1, Windows 95, Windows 98 and
Windows NT. You access your mobile phone’s SIM card using a suitable
smart-card reader (which is often included in the PhoneFile PRO
package).
With PhoneFile PRO you can maintain your SIM card’s phonebook as a
PC file, allowing you to keep a backup of your important contact
numbers, modify the stored details “off-line”, or even maintain several
phonebooks for yourself or for different users.
You can edit the phonebook data on your SIM card directly, so that all
the changes that you make are immediately applied to the card. You can
quickly make major changes and then put the card back into your phone
for use without delay.
You can import data from your favourite contacts management software
or other databases using the import wizard and then transfer phone
numbers selectively or in batches to your card.
You can export your phonebook data in a format suitable for reading into
many other applications and databases using the export wizard
The contents of your SIM card phonebook and all the files created by
PhoneFile PRO can of course be printed in a convenient format to
provide you with a permanent copy.
You can quickly convert all of your phonebook entries to the standard
international dialling format for when you use your phone overseas. You
can also construct complex GSM commands for diverting and barring
calls, and store these in your SIM card. And, if a national dialling code
renumbering campaign has left some or all of your phonebook entries
invalid, PhoneFile PRO can replace all of the old codes with the new
ones with just a few clicks of the mouse.
Pipistrel PhoneFile PRO
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Other Advanced Features
Many other advanced facilities are available to users with suitable SIM
cards. Depending on the features of your particular SIM card, these may
include:
• SMS message display, editing and printing
• Fixed-dial phonebook display, editing and printing
• Fixed-dial phonebook enabling/disabling
• PIN number enabling, disabling and changing
• SIM card unlocking
• Last numbers dialled display and printing
• Own phone number(s) display and printing
• Preferred networks display and printing
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SmartCard Readers
Compatible Readers
PhoneFile PRO is often supplied complete with a SmartCard reader that
can read full-sized GSM SIM cards, and a special adapter card which
allows you to insert a GSM mini-SIM, as used in many mobile phone
models (see “Mini-SIM Cards”.)
Your PhoneFile PRO package will include details of any supplied reader,
including instructions on how to insert and remove your SIM card, and
how to attach the reader to your PC.
You can usually change certain settings appropriate to the reader you are
using (for example the port or drive to be used) and in some cases you
may also be able to change the type of reader (see “Changing Reader
Options”.)
PhoneFile PRO will also work with any PC/SC compatible smartcard
reader, when running on an operating system that supports this standard.
In order to use this feature, you should first ensure that the PC/SC base
components and drivers supplied with the smartcard reader itself are
installed and operational – these drivers are not normally supplied with
PhoneFile PRO.

Mini-SIM Cards
If you have a mobile phone with a mini-SIM you will need to use the
mini-SIM adapter card supplied with your PhoneFile PRO package. The
mini-SIM is inserted into the pocket of the adapter card according to the
diagram on it. The adapter card is then inserted into the smartcard reader
the same way as a standard SIM card.
Care should be taken to ensure that your mini-SIM is seated correctly in
the adapter card, so that the cut-off corner aligns correctly with the
diagram (the right way round) and that the gold contact pads are clearly
visible through the hole in the adapter card (the right way up!)
Failure to insert your mini-SIM in the adapter the right way round and/or
the right way up will prevent the reader from reading your card, and
could damage the reader or adapter card.
When you have finished editing your data with PhoneFile PRO you
should remove your mini-SIM carefully from the adapter card, by gently
Pipistrel PhoneFile PRO
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pressing on the gold contact area, and sliding the mini-SIM out of the
retaining pocket. You should immediately replace your mini-SIM into
your phone to prevent loss or damage.
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Installation/Setup
Installing PhoneFile PRO
The PhoneFile PRO package includes one or more installation disks,
which can be used to quickly install the software and associated files onto
any supported PC. You will have received floppy disks or a CD-ROM,
with software designed for all 32-bit versions of Windows (Windows ’95,
’98, NT) and in some cases for 16-bit Windows 3.1x also.

To install the software on your PC, simply
follow the instructions below:1.

2.

3.

4.
5.

6.

If you are running Windows 3.1x, select the 16-bit
installation disk and insert it into an appropriate floppy
disk drive. From the Program Manager choose File and
then Run. Enter the letter of your floppy drive followed by
a colon (e.g. “A:”) and then type “setup.exe”. Skip to step
3 below.
If you are running Windows ’95, ’98, NT, select the first
32-bit installation disk and insert it into an appropriate
floppy disk drive, or insert the installation CD into your
CD or DVD drive. Choose Start and then Run. Enter the
letter of your floppy or CD drive, followed by a colon (e.g.
“A:” or “D:”) and then type “setup.exe”.
Click OK and the system will start the installation
process. Follow the instructions on the screen until the
installation is complete.
After the installation is complete remove the setup disk
from the disk drive and store your disks away safely.
If you are running Windows NT, you will be prompted to
reboot the computer. Otherwise, you can choose to read
the PhoneFile PRO readme file (for any latest updated
information) or launch the PhoneFile PRO application.
The PhoneFile Pro application is launched using the new
icon installed in the Start menu in Windows ’95, ‘98 or
NT or from the Program Manager in Windows 3.1x.
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Getting Started
The Quick Guide
To start the PhoneFile PRO program, double click the PhoneFile PRO
icon in the Program Manager, or select it from the Start menu.
You should see a screen similar to the one shown below:

PhoneFile PRO uses two “grids” to display the names and phone
numbers you are working with. The one on the left hand side represents a
disk file, whilst the one on the right represents the contents of your
mobile phone’s SIM card, once it has been read into the PC using a
smartcard reader.
Each grid can be opened and closed using standard Windows menu
commands, or by using the buttons on the toolbar. So, to read and edit
your SIM card, simply insert the SIM card into the smartcard reader,
insert (or connect) the reader into (to) your PC, and select Card - Open.
You will be prompted to enter your PIN number if the SIM card has been
protected in this way (see “PIN Numbers”). PhoneFile PRO has facilities
to enable and disable PIN checking (see “Enable/Disable PIN”.)
Once you have opened your card, you can edit the entries directly by
double-clicking on a line in the card grid, or by selecting the line using
Pipistrel PhoneFile PRO
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the mouse or keyboard and pressing Enter. PhoneFile PRO will not allow
you to enter data that is invalid, or too long for your SIM card to store.
You can simply copy the entire card contents to the File Grid by pressing
the central “Copy Card” button, and then save it in the standard SIM-file
format by selecting the File menu followed by Save, and entering a
suitable filename. This is now your backup copy stored on your PC.
PhoneFile PRO provides many ways to move and edit phonebook entries.
You can select multiple entries using the standard Windows methods.
You can click the right mouse button over a phonebook entry, or a
selected block of entries, to access many functions on a convenient popup menu. You can drag one or more entries by holding down the left
mouse button and moving to a different location.

The PhoneFile PRO User Interface
PhoneFile PRO has a number of features that should be familiar to most
PC users. These include menus and a toolbar, plus two spreadsheet-like
grids displaying file and card data. There is also a pair of copy buttons
between the grids, and a status bar at the bottom of the window. Some of
these features can be turned on or off using the Preferences function in
the File menu (see “PhoneFile PRO Preferences”.)

Menus
The menus provide access to all the functions available in PhoneFile
PRO, and are organised in the standard Windows manner. Note that the
Card menu provides items like “open”, “close” and “print” functions that
relate directly to the SIM card that is inserted in the smartcard reader.
For instance choosing “open” will cause contents of the SIM card to be
displayed in the right-hand grid. The File menu provides similar
functions that work with files stored on your computer, that are displayed
in the left-hand grid.

Toolbar
The toolbar appears just below the menus, and contains buttons that
provide quick access to the most common menu functions. The display of
the toolbar is optional, and you can change the size of the buttons to suit
your needs (see “PhoneFile PRO Preferences”.) Tool tips are another
optional feature that can provide additional help on each of the buttons.
Leave your mouse stationary over a button for a few seconds, and
PhoneFile PRO tells you what the button does.
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File and Card Grids
The File Grid shown on the left side of the PhoneFile PRO window
displays the contents of the current PC file. As with most Windows
programs, this can be an ‘untitled’file that you may have just created, or
it can be a named file from your PC’s disk, which you have opened or
saved.
Three columns are displayed in each grid, showing you the entry number
for each line, followed by the name and phone number fields. The width
of the name and phone number fields can be changed by clicking on and
then dragging the black line between the name and number areas in the
grid header.
There is always a final entry in the File Grid, marked with an asterisk
(“*”). This represents a “new” entry, and is used as the space to add
entries to the end of existing (or empty) files.
The Card Grid on the right side of the window represents the contents of
the SIM card that has been inserted in the smart-card reader and
“opened” or read. It operates similarly to the File Grid, apart from the
number of entries, and their maximum length, being fixed by the SIM
card manufacturer (see “SIM Card Properties”.) Fortunately PhoneFile
PRO automatically detects and handles this for you.
During operation, only one of the two grids, card or file, can be “active”.
This is shown by the colour of the entry number header (“#”) changing
from black to blue. This determines, for instance, which of the grids will
be affected when you choose a function such as “Sort”.
Changes that are made to the contents of your SIM card can take some
time to write to the card, especially if you have changed many entries at
once, and so PhoneFile PRO performs this operation in the background.
The entry number for each line of the Card Grid that is to be changed is
shown in red if the change is still pending. It will be changed back to
black once written successfully to the SIM card.

Copy Buttons
There are two copy buttons that appear between the File Grid and the
Card Grid. The first provides quick access to the function that copies the
entire contents of the card across to a file. The second copies the entire
contents of the file to the SIM card (or as many entries as can fit.)

Pipistrel PhoneFile PRO
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Status Bar
The status bar appears at the bottom of the PhoneFile PRO program
window, and will display messages that relate to the current function
being performed, or about to be performed.

Keyboard Operation
Most PhoneFile PRO functions can be controlled from the keyboard using
standard Windows methods, including accessing menus and functions,
and selecting and editing entries in the grids.

Menus
You can call up any menu or menu function by using the Alt key on the
keyboard, along with the letter key shown underlined in the menu, or use
special key press combinations which are shown in the menus alongside
the function. You can also use the cursor arrow keys to move around the
menus after pressing the Alt key.
It is also possible to directly access certain functions from the keyboard
using “shortcuts”. These are displayed in the menus, and provide quick
access to common commands. For instance, pressing Ctrl-O will call up
the File-Open function, pressing Alt-F4 will exit the program.

Navigating the Grids and Selecting Entries
The selection bar (the coloured highlight) marks the entry that will be
affected by an edit, or copied to the clipboard by a Cut or Copy. The
cursor arrows can be used to move the selection bar up and down in the
File and Card grids, and the Tab key moves between them. It is possible
to select multiple entries by using the keyboard arrows and holding down
the Shift key while moving up or down.

Mouse Operation
PhoneFile PRO provides all the standard mouse-driven features you
would expect of a Windows program, including normal and right-button
menus, selection of entries in the grids, drag and drop functionality, and
some additional shortcuts to other functions.

Menus
Standard Windows menus can be called up by clicking the left mouse
button on one of the menu titles at the top of the program window. Any
item or function from that menu can then be chosen simply by moving
12 •Getting Started

Pipistrel PhoneFile PRO

the mouse down to the appropriate line, and clicking the left button
again.
PhoneFile PRO also provides a useful menu of functions whenever the
right mouse button is clicked while pointing at entries in the File or Card
grids. If the right button is clicked while the mouse is over an existing
selected block of entries, then the block is maintained, and any functions
chosen from the menu will apply to all of the selected entries. If the right
button is clicked on an unselected entry, then this entry is selected first,
before the menu is displayed.

Selecting Entries
One or more entries in either the File or Card grid can be selected using
the mouse, in combination with the keyboard. For instance, to select a
complete block of entries, click the mouse on the first entry, then hold
down the Shift key and click the mouse on the last entry in the block. To
select multiple individual entries hold down the Ctrl key whilst clicking
the mouse on each one.

Drag and Drop
PhoneFile PRO provides a useful drag and drop facility that can be used
to organise entries in the File or Card grids, or even copy entries between
the grids. To use the drag and drop facility, click and hold the left mouse
button over one or more selected entries, then, while still holding down
the button, move the mouse to the location where you wish to drop the
entries, and then release the button. PhoneFile PRO also provides
automatic scrolling within the grid boxes to assist you with drag and drop
operations.
If you are dragging entries from one location to another in the same grid,
then PhoneFile PRO will move the entry or entries from the original
location to the chosen new location.
If you drag entries from one grid to the other, then PhoneFile PRO will
copy the selected entries across, leaving the originals unchanged.

Other Mouse Shortcuts
Double-clicking the left mouse button in the File or Card grid name or
number headings will call up an alphabetical sort function on all the
entries in that particular grid (see “Sorting Your Data”.)
Double-clicking on the filename panel above the File grid performs the
File-Open function. Double-clicking on the card number panel above the
Card grid will perform the Card-Open or Card-Close function.

Pipistrel PhoneFile PRO
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Working with Cards & Files
Accessing your SIM Card
The phonebook data held on your SIM card can be edited directly by
keying in changes, or by adding additional details, or by transferring
numbers from existing PC based files.
Your SIM card should first be inserted into the smartcard reader,
referring to the instructions included with your reader. You “open” or
read the card by either choosing Open card from the Card menu or by
clicking on the Open card button in the toolbar. The SIM card number is
immediately displayed within the card number box.
If you have secured your mobile phone’s SIM card with a PIN number,
PhoneFile PRO respects this security feature and you will be asked to
enter your PIN before you may open or read the SIM card (see “PIN
Numbers”.) PhoneFile PRO then checks various parameters on your SIM
card to see if a Fixed-dial phonebook is present and enabled (see
“Enabling Fixed-dial”.) If so, you will be asked to enter a second PIN
number known as PIN2 or otherwise opt to work with the card in readonly mode.
PhoneFile PRO then reads and displays the contents of the phonebook in
the right-hand card grid, ready for you to work with:

Pipistrel PhoneFile PRO
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PIN Numbers
Do not try to guess a PIN number – you have only three attempts before
being locked out of your SIM card! In fact, PhoneFile PRO will not let
you enter a PIN number if there is only 1 try remaining - you will have to
put your SIM card back into your phone in these circumstances.
If you have forgotten your PIN number it is possible to set a new PIN as
long as you know your Personal Unlocking Code (see “Unlocking a SIM
Card”.)

Enable/Disable PIN
The PIN facility can be switched on or off by using the Enable PIN (or
conversely, Disable PIN) function in the Card menu, or by clicking the
Enable PIN (or Disable PIN) button that appears on the card properties
screen. When enabling or disabling PIN protection the system will ask
you to enter the existing PIN number first, so care should be taken to
ensure it is not forgotten even when PIN protection is disabled. Do not try
to guess a PIN number, as you have a limited number of attempts (see
“PIN Numbers”.)
If you do not know your PIN number please refer to the “Unlocking a
SIM card” section. If you wish to change your PIN see “Changing your
PIN number”.

Accessing your Files
PhoneFile PRO allows you to save and recall data files stored on your PC.
You can copy phone number entries back and forth between a file and
your SIM card.
The installation program automatically registers that files with the
extension of .SIM contain PhoneFile PRO data, so that by double clicking
on a .SIM file in File Manager or Explorer will launch PhoneFile PRO,
and open that file for you.

Creating a New File
To create a new PC file choose ‘New’from the File menu, or click on the
New file button on the toolbar. Highlight the blank entry line marked
with a ‘*’and press Enter, or double-click on this line. PhoneFile PRO
will display an edit box into which your names and numbers can be
keyed:
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You can move on to the next line by clicking the Next button (or pressing
Alt-N), and repeat the process until all your names and numbers have
been entered.
The file will stay in the PC’s memory while you continue to use
PhoneFile PRO, but you will need to Save it if you want to recall the data
later.

Saving a File
When all your data has been entered the contents of the File Grid can be
saved by choosing ‘Save’or ‘Save as’from the File menu or clicking the
Save button on the Toolbar. Enter a filename in the dialog box that
appears and click ‘OK’to save the file. PhoneFile PRO saves files with
the default extension .SIM (for example “mike.sim”). This extension
helps you and your software to recognise PhoneFile PRO data files.
The entire contents of a SIM card can be quickly saved as a PC file by
selecting the Copy to File function in the Edit menu or clicking the Copy
card button between the two PhoneFile PRO grids. This will copy all the
numbers from the right grid to the left grid which can then be saved to
disk using the File Save function as described above.

Opening an Existing File
From the File menu choose Open or click the Open icon on the toolbar.
The Open a File dialog box will appear.
Click on the file you want which should be displayed in the list box or
type its name in the File Name box. PhoneFile PRO data files have the
default extension “.SIM”.
If the file is on another drive or directory, select the location using the
lists available.
Finally click OK or double click on the filename and the contents of the
file will be displayed in the left-hand grid. The contents of a grid can be
edited by selecting the appropriate line and pressing Enter, or by doubleclicking the line. The edit box will appear allowing you to make the
appropriate changes.
Pipistrel PhoneFile PRO
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If you wish to add names and numbers to the file click on the blank line
at the bottom of the grid and press Enter. The new number can then be
keyed into the edit box.

Printing your Data
Selecting the Print function from the File menu, or clicking the
appropriate button on the toolbar, will print the contents of the file grid to
your default printer.
Selecting the Print function from the Card menu, or clicking the
appropriate button on the toolbar, will print the contents of a SIM Card
grid to your default printer.
Printer fonts can be changed from the File menu Preferences item (see
“Printer font and language options”.)

Importing Files
To allow data from your existing databases and contact management
software to be used by PhoneFile PRO the system can read files created
by other applications in various formats such as Comma Separated
Variable (CSV) format, TAB separated format, space separated format
and fixed length format. Additional formats may be available from time
to time (See “Enhancing PhoneFile PRO”.)
To import a file choose the Import Wizard from the File menu.
The first Import Wizard dialog box will then appear. Simply follow the
Wizards’instructions, and press the Next button after each step. If you
want to change or correct a step, simply press the Back button one or
more times.
The first step is to identify the format or source of your data. Choose the
appropriate item from the drop down list, and then press the Next button.
If you are importing a file, for instance a comma separated file, the next
step is usually to enter the filename. You can do this by typing the name
in directly, or by pressing the Browse button and locating the file on your
PC’s disk.
With most file imports, you can then identify where PhoneFile PRO
should get the contact names and phone numbers to import, and how
exactly it should process them. When all of the steps have been
completed, press the Finish button and your data is imported into the File
grid.
When PhoneFile PRO imports a file, it effectively creates a new, untitled,
data file and then enters all the new records into this file for you. It is
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therefore a good idea to save your new data file in the standard format,
giving it a name and a .SIM extension (see “Saving a File”.) Your saved
file can then be edited or used to transfer numbers to your SIM card in
the normal way.
If you are unsure of the formats that your existing database or contact
management software can use, consult its documentation first. It is very
likely that you can save your data in at least one of the supported formats.

Exporting Files
You may be able to use the standard PhoneFile PRO file format (.sim) to
transfer information into other applications, since the data is stored in
comma separated variable (“CSV”) format. Alternatively, you can use the
PhoneFile PRO Export Wizard to save your data in various formats, and
with various additional options.
If you are unsure of the formats that your existing database or contact
management software can use, consult its documentation first. It is very
likely that you can use data in at least one of the available formats.
In order to export a file, choose the Export Wizard from the File menu.
The first Export Wizard dialog box will then appear. Simply follow the
Wizards’instructions, and press the Next button after each step. If you
want to change or correct a step, simply press the Back button one or
more times.
The first step is to identify the format for your exported data. Choose the
appropriate item from the drop down list, and then press the Next button.
The next step is usually to enter the name of the file you wish to create.
You can do this by typing the name in directly, or by pressing the Browse
button.
With most file exports, you can then choose how exactly the data records
should be written. When all of the steps have been completed, press the
Finish button and the contents of the File grid is exported to the chosen
file.

Pipistrel PhoneFile PRO
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Editing Data
Editing your Data
If you simply wish to change an entry on the SIM card or in your file, just
select the line to be changed and press the Enter key, or double-click that
line. An edit box appears and data can either be amended or added to as
required.

When the edit box is displayed, you can easily move around the card or
file data using the Next, Prev, First and Last buttons.
To transfer the contents of an entire file to your SIM card choose Copy
file to Card from the File menu or Click the Copy File button in the
centre of the screen and all the numbers will be copied to the SIM card.
(NB The manufacturer of your SIM card has pre-set the total quantity of
names and numbers that can be stored on the card. You cannot, therefore,
copy more names and numbers than the SIM card allows.)
Selective transfers can be performed by highlighting the required number
or group of numbers and then dragging and dropping them where you
want them to be on the SIM card. This performs a Paste Insert operation
so that existing data on the card is not overwritten. If you do wish to
overwrite existing numbers use the Copy and Paste functions that are
available in the Edit menu. All Edit functions are also available from the
Right mouse button menu.

Searching for Items
The Search menu provides functions for finding specified numbers or
words within your SIM card or PC file. To search for something, make
sure that the required grid is currently selected, and then choose Search –
Find, or press Ctrl-F. You can then enter a string that you are looking for
and press the Find button.
Pipistrel PhoneFile PRO
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If the item is located, the selection bar will be moved to highlight the first
occurrence of it. You can then search for subsequent occurrences of the
same string by choosing Search – Find Next or by pressing Ctrl-G.
Alternatively you can click on Select All, which will highlight all the
entries that match the string you have provided.
You can also use the Find function to identify duplicate lines in the card
or file, by clicking the Repeated Rows box. Find functions are also
available from the Right mouse button menu.

Find and Replace
You can use the find and replace function to make multiple changes to
the contents of your SIM card or PC file. To do this, make sure that the
required grid is currently selected, and then choose Find and replace
from the Search menu. You can then enter the string that you want to
change, and the string that you want to replace it with. You can also
specify if you want PhoneFile PRO to search just the names, just the
numbers, or all the information in the grid.

Cut and Paste
The Edit menu and the icons on the toolbar provide full facilities for
Cutting or Copying and Pasting to, and from, the Clipboard. Simply
select the entry or entries you wish to Cut or Copy and then choose the
appropriate action from the edit menu or click the required icon from the
toolbar.
You can copy and paste entries between the File Grid and the Card Grid,
as well as between different locations within the SIM card. You can also
use the drag and drop mouse features to perform similar operations.
When pasting entries you should click and select the line where the data
will be pasted to, and then choose Paste or Paste Insert from the Edit
menu. Choosing Paste will overwrite existing data, while Paste Insert
will add the entry at the position chosen, moving subsequent entries
down to make room.
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When pasting data to the card, the Paste functions will apply various
automatic formatting rules to the information to ensure it is a valid entry,
before it is written to the card.
Cut, Copy and Paste functions are also available from the Right mouse
button menu.

Sorting your Data
The entire contents of a File or a Card grid can be automatically sorted
into alphabetical order using the sort command in the Edit menu. Make
sure that the correct grid is selected first. Similarly, a highlighted block
of entries from a File or a Card grid can be sorted automatically, allowing
the user to preserve the location of any numbers placed in ‘speed
dialling’locations. In this case the confirmation dialog says, “Sort
selected lines only”, click OK to confirm. To sort the whole file or grid at
this point you could click and remove the check mark in the box beside
this message. Sort functions can also perform by double-clicking in the
grid column name and number heading, and from the Right mouse
button menu.

Capitalising Names
Any files or SIM card phonebooks where the names are made up of just
capital letters can easily be converted. The Capitalise function converts
names so that each word will start with a capital letter and the other
following letters are changed to lower case (non-capital) letters. i.e.
‘JOHN SMITH’will become the more attractive ‘John Smith’(in your
phone display).
In order to capitalise names in the File or the Card grid, first make sure
the appropriate grid is selected, and then the choose the Capitalise
function from the Edit menu. The Capitalise function is also available
from the Right mouse button menu.

Internationalising Numbers
You can automatically convert your phone numbers into international
format using PhoneFile PRO’s Internationalise function available from
the Edit menu. This will prompt you to enter the international prefix that
you wish to use – this will normally be the prefix for your “home”
country – e.g. 44 for the UK. PhoneFile PRO will then search for any
numbers in the card or file that start with a zero, and replace this digit
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with the prefix that you have specified. The Internationalise function is
also available from the Right mouse button menu.

Automatic Formatting
PhoneFile PRO provides a number of automatic formatting functions for
the data that you write to your SIM card. For instance, PhoneFile PRO
will remove all spaces from phone numbers when they are copied to the
card. It can optionally suggest shortened names if the original entry is too
long to be stored in the SIM card’s memory (see “Operational Options”).
The length of name available is dependent on the card itself, and can be
limited to 8 characters in some instances.

Other options include an intelligent method of shuffling down entries in
your SIM card, when you paste numbers into blank areas and automated
Capitalisation as you type (see “Operational Options”.)
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Advanced Operation
Changing your PIN Number
You can easily change your PIN number by selecting Change PIN from
the Card menu, or by selecting Change PIN from the card properties
window. As a security feature the system will ask you to enter the
existing PIN number first.
Enter the new PIN number you have chosen in the space provided and
then re-enter the new PIN in the ‘new PIN – again’space to confirm that
you have typed it correctly. Great care should be taken to ensure that the
new PIN number is not forgotten.

Unlocking a SIM Card
If you have forgotten your PIN number or have a locked SIM card, you
will need to obtain your Personal Unlocking Key (PUK code) from your
mobile phone supplier before being able to re-activate it or set a new PIN.
Do not try to guess a PUK code – you have only ten attempts before being
PERMANENTLY locked out of your SIM card (and having to buy a new
one!)
If opening a SIM card to which you have forgotten the PIN number, you
can use the “I’ve forgotten” (my PIN number) button to move to the
‘Unblocking Card’window.
When you try to open a SIM card that is already locked PhoneFile PRO
automatically detects this and opens the ‘Unblock Card’Window.
You can now enter the PUK code to Unblock (unlock) the SIM card:
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When entering the PUK code, you must also set a new PIN number.
PhoneFile PRO asks you to enter this twice in order to confirm that you
have typed it correctly, before proceeding with opening the card. Care
should be taken to ensure that you do not forget your new PIN number.

SIM Card Properties
Various properties, values and features of the SIM card can be displayed
by selecting the Properties function from the Card menu:

The information shown includes the serial number of the SIM card; the
type of SIM card you have (e.g. Phase 2 type) and whether a PIN is
required to access the card.
Also displayed is the maximum number of phone numbers the card can
store; the maximum length of name that can be stored and the maximum
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length of the telephone number that can be stored (these maximums are
set by the SIM card manufacturer.)
Similarly, if your SIM card is capable of supporting a Fixed dial
phonebook the values for the maximum number of phone numbers,
maximum length of names, and telephone number that can be stored are
displayed (see “Enable Fixed dial”.)
Other information displayed includes details of the smartcard reader and
the reader driver version number information that should be provided
with any technical query.

Additional Card Properties
After choosing Card – Properties, selecting the More.. button provides
some additional details of information stored on the SIM card. These
details may not always be available, as they depend on the type of SIM
card and phone that you are using:

Items that may be available are:
Phone Numbers (MSISDN): if implemented, provides the number or
numbers allocated to the SIM card owner for different services (basically,
your phone number) which are all set by your service provider
Last Numbers Dialled: if implemented in both the SIM card and the
phone, displays the last phone numbers dialled.
Networks (PLMN) is the list of preferred and forbidden networks
available to the subscriber.
None of the above items can be edited using PhoneFile PRO.
Using the Print button prints out any available ‘More Card Information’
as above to your default printer.
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The OK button closes the ‘More Card Information’Window and returns
you to the ‘Card Properties’window.

Programming GSM divert strings
You can use PhoneFile PRO to program special strings into your phone’s
memory, which can be used to set up, change or cancel various features
available on the GSM network, including phone diversions (diverts) if
your number is busy or out of coverage or your phone is switched off.
By storing these strings in the first ten memory slots of your SIM card,
you can quickly access them using the speed-dial feature available on
many models of GSM phone (see your mobile phone manual.)
To use this feature, select the Insert GSM Command from the Edit menu.
You will be presented with a list of available commands, as well as some
entry boxes for selecting options or entering numbers as required.
Depending on the command that you choose, these entry boxes will have
different headings and uses.
For example, if you choose the “Divert on no answer” command, you can
then create a string to Activate this command, in which case you must
enter the destination phone number plus the type of calls you wish to be
diverted in this way. PhoneFile PRO generates the appropriate command
string and displays this towards the bottom of the window, along with a
suggested name entry that you can change before pressing OK to insert
this entry into the selected grid.
Note that services available on your GSM network depend on the network
operator, therefore there is no guarantee that all of these strings will work
as expected.

SMS Messages
Another feature of the GSM network is that it gives the user with a
suitably enabled phone, SIM card and service access the ability to send
other users text messages for display directly on their phone (like a
pager.) The problem with these Short Messages (usually up to 168
characters long) is that it is awkward and time consuming to type a
message using a phone keypad. PhoneFile PRO gives the suitably
equipped user the ability to view, edit, create, save and print SMS
messages at the PC with a conventional keyboard, making SMS
messaging really usable.
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You gain access to this facility through the Card Properties function in
the Card menu and then clicking the ‘SMS..’button.
PhoneFile PRO then reads your SIM and displays any SMS messages that
are stored on it, along with any other relevant information including the
number of message ‘slots’available and the status of the messages:

By using the Next and Prev buttons you can then cycle through any
stored SMS messages and any ‘empty’slots. You can edit any stored
message, or create new ones in empty slots, by placing the mouse cursor
directly on to the message with a left mouse button click and then by
typing or editing with the PC Keyboard. Any displayed message that you
no longer require can be remove with the Clear (the message) button.
Having completed an edit, if you choose to move to another message, or
choose to close the SMS message window using the OK button, you will
be asked if you wish to save your changes to the SIM card. Choosing
‘Yes’will write your changes to the SIM and choosing ‘No’will prevent
any changes being written to the SIM. Alternatively you can click on the
Save button after making your changes.
All your stored messages and the SIM card number can be printed to your
default printer by using the Print button displayed in the Short message
information window.
Note: If your card reader has a ‘Sleep’battery saving mode and you take
a long time editing and saving a message, if sleep mode becomes
activated you could lose your changes, and will have to re-open the SIM
again.

Enabling Fixed-dial
If your SIM card is capable of supporting Fixed-dial numbers you can
turn the Fixed-dial feature on by choosing Enable Fixed-dial from the
Card Menu, or by pressing the Fixed-dial On button in the Card
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Properties window . If Fixed-dial is already enabled PhoneFile PRO
detects this and these items become Fixed-dial Off switches.
By turning Fixed-dial on you prevent the phone into which the SIM card
is inserted from dialling any number that is not listed in the Fixed-dial
phonebook (see “card properties” for its size), emergency numbers
excepted. Fixed-dial may be useful to prevent a phone that you provide
for someone else being overly used. Note that only certain models of
phone implement Fixed-dial functionality, and that therefore you may not
be able to use this feature, even if it is available on your card.
If your SIM card is capable of supporting Fixed-dial, before proceeding
you will need to know your PIN2 (PIN two) number. You may need to
contact your service provider for your PIN2 if it was not given to you
with your phone documentation.
A PIN2 number is different to a PIN (PIN one) number, as it provides
access to different functions. It is, therefore, very unlikely to be the same
as your PIN number. Do not try to guess a PIN2 number, as you have a
limited number of attempts before being locked out of your SIM card (see
“Unlocking your SIM Card”.)
Having correctly entered your PIN2, Fixed-dial is enabled. As the SIM
card phonebook functions have now been changed the card is closed and
you will have to re-open (re-read) the card to gain access to the Fixeddial phonebook. Do this by opening the card in the normal way (see
“Accessing your SIM card”) and entering firstly your PIN number and
secondly your PIN2 number as asked to. You may now access and edit
your Fixed-dial phonebook as you would a normal phonebook (see
“Editing your Data”.)
If you have forgotten your PIN2 you may enter your PUK2 code number
by selecting the “I’ve forgotten” button at that point, following the
instructions and warnings listed under the “Unlocking a SIM card”
section.

Disabling Fixed-dial
To disable Fixed-dial choose Disable Fixed-dial from the Card Menu, or
press the Fixed-dial Off button on the Card Properties window (if Fixeddial is already off PhoneFile PRO detects this and these items become
Fixed-dial On switches). You will then be asked to enter your PIN2
number (see “PIN2 Numbers”) and Fixed-dial is turned off. As the SIM
card’s phonebook functions have now been changed the card is closed
and you will have to re-open (re-read) the card to gain access to the
normal phonebook (see “Accessing your SIM Card”.)
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Customising PhoneFile PRO
PhoneFile PRO Preferences
Several options are available which allow you to customise PhoneFile
PRO and choose how the program works. These options can be found by
selecting Preferences from the File menu:

If you make any changes in the preference window (see relevant sections)
your changes may be saved by selecting the ‘OK’button or cancelled by
selecting the ‘Cancel’Button.

Display Options
If the ‘Show Popup help’box is checked the system will pop up a
description of any button on the toolbar when the mouse pointer is parked
over the button for a couple of seconds. Uncheck this box to turn off this
feature when you are familiar with PhoneFile PRO operations.
The PhoneFile PRO “splash screen” that appears briefly when the
PhoneFile PRO program starts up can be suppressed by unchecking the
‘Show Splash screen’box. The Toolbar and Centre buttons can be
removed or their sizes altered by selecting the required choice from the
drop down menu, which appears when the arrow to the right of the box is
clicked. You can also choose the style that the buttons operate in – either
Normal or Active.
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Operational Options
The Preferences screen also allows you to determine how PhoneFile PRO
operates. If the boxes are checked PhoneFile PRO will:
• Suggest shortened names, if the entry is too long for the
SIM card that you are using, when you are transferring
data to it;
• Automatically add capitals as you type names
(Capitalise);
• Remove any blank rows on the card between numbers that
are being inserted (this helps to minimise the movement
of entries on a card, unless absolutely necessary);
• Remove any blank rows from the end of the file, after
certain operations (this helps to minimise the size of the
files that you save on your PC).

Printer Font and Language options
The font that PhoneFile PRO uses for print outs can also be changed if
desired. Select a different font by selecting the required choice from the
drop down menu, which appears when the arrow to the right of the box is
clicked. If you have a problem printing legibly to a particular printer the
problem can often be solved by picking a font that may be more suited to
your printers capabilities.
If you have a multi-language version of PhoneFile PRO you can select the
required language from the drop down menu, which appears when the
arrow to the right of the box is clicked.

Changing Reader Options
In order to change the smartcard reader or its settings, choose Card –
Reader. If more than one type of reader is available, you can select the
reader from the drop-down list. To change the settings specific to your
reader, such as the port or drive to be used, press the Configure button.
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Enhancing PhoneFile PRO
Downloading Enhancements
Various elements of the PhoneFile PRO application can be upgraded by
downloading enhancements over the Internet. In particular, files may be
available that provide drivers for alternative smartcard readers, additional
languages, and enhanced import/export wizards.
In order to check availability, please visit the PhoneFile PRO web site at:
http://www.pipistrel.com/phonefile
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Technical Support
Getting Technical Support
For help and information about using your PhoneFile PRO software, you
can contact Pipistrel in a number of ways. If you have access to the
Internet’s World Wide Web or to an email service, we encourage you to
use these facilities first. Alternatively, you can contact Pipistrel by fax.
Method

Location

Email:

phonefile-support@pipistrel.com

World Wide Web:

http://www.pipistrel.com/phonefile

Fax:

+44 (0)1483 440200

To speed up the process of helping you to use PhoneFile PRO, have the
following information available before you call:
Software version number
Your PhoneFile PRO Serial number
SmartCard reader model and serial number
GSM network operator name
Computer brand, model and any additional hardware
Operating System name and version number
Specific steps to re-create the problem, if applicable
You can find the software version and serial numbers by choosing About
PhoneFile PRO from the Help menu. You may also be asked for
additional information from this screen.
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Glossary of Terms
CSV
The Comma Separated Variable file format, which is a text file where
each field is separated by commas, and optionally enclosed in double
quotes.

Fixed-dial
A feature of certain SIM cards and GSM phones that prevents the phone
from calling numbers other than those programmed into the card, when
in Fixed-dial mode.

GSM
Global System for Mobile communications - the standard for digital
mobile telephony now running in over 70 countries world-wide.
Variations include GSM-900 (previously just GSM), GSM-1800 and
GSM-1900 (previously known as PCS or PCN.)

Mini-SIM
A special sized version of the SIM card often used in smaller GSM
phones.

PC/SC
An emerging standard for Smartcard reader devices that are attached to
PC's.

PIN
A Personal Identity Number used to access secure information such as
that stored on a smartcard.

PIN2
A secondary PIN number used to protect certain advanced facilities on a
SIM card. It is not the same as the normal PIN.

PUK
A Personal Unlocking Code, that can be used to re-enable a SIM card
after the wrong PIN has been entered, or to set a new PIN when the old
one has been forgotten.
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SIM card
A smartcard known as the Subscriber Identity Module which is used to
identify a subscriber to the GSM network. A GSM phone must have a
SIM card inserted before it can be used.

SmartCard
A plastic card, normally the same size as a credit card, containing an
embedded microprocessor and storage electronics.

SMS
Short Message Service - a text message that you can send to or from a
mobile phone. All GSM phones have the ability to receive SMS
messages; some can also send them.
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